Quite Software  

You are here: Quite > Support > Acrobat X (10.0)


Acrobat X (10.0) support information

Information updated 9 June, 2014

What is Acrobat X (10.0)?

Acrobat X is the marketing name of Adobe's new 2010 release of Acrobat, which is also version ten (10.0). It was released in November 2010. There are more details on Adobe's site. Quite Software has worked extensively with Adobe to make sure that our products are made compatible.

Will Quite plug-ins work with Acrobat X (10.0)?

An upgrade to version 3 of our Imposition plug-ins is needed for full compatibility.

What is the product status?

Quite Imposing/Quite Imposing Plus: some issues with version 2.9b but these have been resolved in version 3.
Quite a Box of Tricks: new release available (1.8e)
Quite Revealing: new release available (1.8e)

Where can I get updates?

You can download a preview of Quite Imposing Plus here. There will be a charge for the final release. At this time, there is no preview of Quite Imposing, only Quite Imposing Plus. You can download Quite a Box of Tricks from here and Quite Revealing from here. These are free updates for registered users.

"Not a compatible copy of Acrobat" with 10.1.10

If Acrobat X is upgraded to 10.1.10 or later on Mac OS, you may get the error "Sorry, that does not seem to be a compatible copy of Adobe Acrobat" when installing. Please upgrade to
  • Quite Imposing or Quite Imposing Plus 3.0j
  • Quite A Box Of Tricks 1.8i
  • Quite Revealing 1.8i